[RESOLVED] i3-wss11 :: Service Interruption Sunday 8th March 2020 18:55:22


mi3-wss11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:58 PM: All services should be back online at this time. Please reach out to our support team should you experience any further issues.