[RESOLVED]Singapore DC :: Intermittent Latency Issues Friday 28th February 2020 06:07:59


One of the up-link providers in our Singapore data center is currently experiencing issues. Users may experience intermittent service degradation as a result. Our Network Engineers are currently working on this issue. We will provide updates as more details are made available.

Update 2:15AM EST, Feb-29: Our network engineers are staying on top of this situation and continuing to work with our up-link provider to correct any further issues.

Update 11:06 AM EST, Mar-3: Our network engineers have resolved this matter and any latency issues should now be resolved at this time.