[RESOLVED]MI3-WSS11 Sunday 16th February 2020 20:56:14


mi3-wss11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATED: 2/14/20 2:30AM [RESOLVED] Our System Operations team has stabilized mi3-wss11. We will continue to monitor the server's stability and performance.