Singapore DC :: Intermittent Latency Issues Friday 7th February 2020 04:14:37


One of the up-link providers in our Singapore datacenter is currently experiencing issues. Users may experience intermittent service degradation as a result. Our Network Engineers are currently working on this issue. We will provide updates as more details are made available.

UPDATE :: As of 1:40 PM EDT We can report there are still a number of customers affected with some latency issues but we're working with our vendors on this issue.  More updates as we know more.

UPDATE February 10, 2020 12:45 PM EST: Our System Operations team is still working with the vendor to correct any remaining networking issues. We will continue to provide updates as they're made available.

UPDATE February 17, 2020 04:25 PM EST:  Network connectivity has been back to normal for a few days. Our team has been monitoring the network and has found no issues since connectivity has been fully restored. We are hence marking this issue resolved. If you continue to encounter any issues, please do not hesitate to contact support.