[RESOLVED]Singapore :: Connectivity Wednesday 5th February 2020 17:30:15


One of the uplink providers in our Singapore data center is currently experiencing issues. Users usually routed through the affected provider may experience service degradation as a result. Our Network Engineers are currently working on this issue. We will provide updates as more details are made available.

UPDATE 02/06/2020 10:00 AM EST: The network has been stabilized and we will continue to monitor the network's stability & performance.