[RESOLVED]Michigan :: Network Interruption Friday 17th January 2020 23:50:00


Some servers hosted in our Michigan facility are currently experiencing a Network interruption. Users hosted on these servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 5:40AM: Our Engineering and Support Operation teams were able to correct this issue and it is currently resolved. We'll continue to monitor the service for any issues.

Update 5:50AM: There are still some lingering issues on the service at this time. Our Engineers and System Operations team are currently working to resolve the issue.

Update 6:00AM: Our Support Operations team was able to identify the issue causing the lingering trouble and correct it. We'll continue to monitor the service for any issues.