[RESOLVED]mi3-wtr1 :: Service Interruption Wednesday 1st January 2020 06:26:39


mi3-wtr1.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:35 AM EST: Our System Operations team has resolved this matter and all services are back online.