Network Interruption :: Singapore Thursday 5th December 2019 17:17:52


Some servers hosted in our Singapore facility are  currently experiencing a Network interruption. Users hosted on these servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:50PM EST: Our Engineers are still working on this. We will post updates as more information becomes available. We sincerely apologize for the inconvenience in this regard.

UPDATE  01:33AM (Dec-06) EST: Our Engineers team is continuing to work on this incident. We will update this thread as more information is made available in this regard 

UPDATE 01:45 AM (Dec-06)  EST: Our Engineers team has mitigated a DDoS attack and all services are back online. We will continue to monitor the situation closely.