[UPDATED] Dedicated Servers :: Service Interr Sunday 17th November 2019 15:48:00


Some of our Dedicated Servers are currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 9:28 PM EST: Our Operations department has been able to stabilize the service on the majority of the affected dedicated servers. We will provide updates as more details are made available.

UPDATE As of 10:08PM EST: Our Operations department has been able to stabilize the service on the affected dedicated servers.

UPDATE as of 18 November 2019 at 2:50 AM EST: Our dedicated servers are once again experiencing a service interruption. Our Engineering team is currently investigating the root cause. We will provide further updates as more details are available.

UPDATE 3:30AM EST: Our Engineering team has found the cause of the recent interruption and is in the process of correcting it. We will continue to monitor all services for any issues.

UPDATE 4:45AM EST: Our Engineering team has been able to stabilize the service on the affected dedicated servers.