LetsEncrypt 3rd Party Database Issue. Sunday 17th November 2019 08:01:35


LetsEncrypt is currently experiencing a service interruption to its database services on their side. Users trying to renew or order new LetsEncrypt certificates will experience service disruption as a result.  Unfortunately this is out of our control and it is to do with a LetsEncrypt service unavailable.  More information can be found here: https://letsencrypt.status.io/

UPDATE As of 3:20PM EST :: LetsEncrypt is starting to come back to normal, however some domains will have delays in renewals and new issues due to rate limits being hit in getting domains installed, LetsEncrypt are working on this as per their status post above.

UPDATE As of 6:06 PM EST :: LetsEncrypt is back to normaL.