[RESOLVED]mi3-sr5 :: Service Interruption Friday 15th November 2019 08:44:00


mi3-sr5.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 1:50 PM EST: Our System Operations team has resolved this matter and all services are back online.