Barracuda Spam Filtering :: Service Interruption Wednesday 13th November 2019 08:29:00


Our Barracuda spam filtering service is currently experiencing a service interruption. Users with Barracuda spam filtering enabled will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 2:33 PM EST: Our System Operations team continues to work on restoring service as quickly as possible. We will provide updates as they are made available.

UPDATE 3:35 PM EST: Our System Operations team continues to work on restoring service as quickly as possible. We will provide updates as they are made available.

UPDATE 3:40 PM EST: Our System Operations team has resolved this matter and the Barracuda service is working as expected at this time. If you experience further issues please open a support ticket through our customer portal.

UPDATE 4:00 PM EST: Our Barracuda spam filtering service is currently experiencing a service interruption. Users with Barracuda spam filtering enabled will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 5:00 PM EST: Service has been largely restored. Our System Operations team is still working to ensure full services are restored and maintained. We will post updates as and when more information becomes available in this regard.

UPDATE10:39 PM EST: Our System Operations team has resolved this issue, and the Barracuda service is back online.