[Resolved] a2hosting.com site Saturday 9th November 2019 17:52:23


a2hosting.com sie is currently experiencing a service interruption. This does NOT affect users' accounts, websites nor access to the customer portal. We will provide updates as more details are made available.

[RESOLVED] Update at 10:56 pm.  A2hosting.com site is fully functional.