[RESOLVED] MI3-SR5 :: Service Interruption Monday 4th November 2019 10:41:11


MI3-SR5  is currently experiencing an interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 3:50PM EST :: This issue has now been resolved and if you still see issues please do get in touch.