[RESOLVED] MI3-SR13 :: Service Interruption Wednesday 30th October 2019 04:29:01


MI3-SR13  is currently experiencing an interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 8:40AM EDT :: Our system admin team have resolved this issue and your sites will be operating as normal, please let us know if you're still experiencing issues.