[RESOLVED] Phone Service Interruption Wednesday 16th October 2019 11:30:29


Our phone system is currently experiencing a service interruption. Please use our Live Chat or open a ticket while our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

Update 3:52PM :: Our phone system is once again online. We will continue to monitor the service for any additional issues.