[RESOLVED]Dedicated Servers: Service Interruption Monday 14th October 2019 08:35:22


Multiple Dedicated servers in our Michigan DC are currently experiencing a service interruption. Users hosted on these servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 2:15 PM EDT: Our System Operations continues to work on restoring service to all servers. We will continue to provide updates as they're made available.

UPDATE 3:12 PM EDT: Any affected servers are back online but we are still monitoring the situation internally.   If you are seeing any issues with your service please do not hesitate in getting in touch via ticket or livechat.