Phone Service Interruption Sunday 13th October 2019 03:03:48


Our phone system is currently experiencing a service interruption. Please use our Live Chat or open a ticket while our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

Update 7:30AM: Our Operations team has identified the cause of this issue and is currently working with our vendors to resolve the trouble. Updates will be provided as they are available.

Update 8:20AM: Our phone system is once again online. We will continue to monitor the service for any additional issues.