[RESOLVED] MI3-WSS11 :: Service Interruption Saturday 21st September 2019 11:55:15


MI3-WSS11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 4:18 PM Eastern :: mi3-wss11 has returned to normal operations and is back online.