[RESOLVED]Phone Service Interruption Friday 6th September 2019 07:21:01


Our phone system is currently experiencing a service interruption. Please use our Live Chat or open a ticket while our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 11:48 AM EDT:  Phones have been back online for the last 10 minutes and appear to be stable.