A2SSR18 :: Email Services Thursday 14th December 2017 10:06:02


A2SSR18 is currently experiencing an interruption with Email Services. Users will experience service degradation as a result.

Update 16:30 EST :: SSR18 is still experiencing issues with email. We are currently working on the issue.

Update 17:30 EST :: SSR18's mail is still having trouble, and our engineering team is working on the issue. We appreciate your patience.

Update 18:30 EST :: We are gald to report that SSR18's email issues are resolved.