[RESOLVED] mi3-wss10 :: Reboot Required Tuesday 20th August 2019 06:58:16


mi3-wss10.a2hosting.com is currently being rebooted to correct an issue. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 11:18 AM EDT: Our System Operations team has confirmed all services are back online.