[RESOLVED]a2ss32 :: Service Interruption Sunday 18th August 2019 15:00:41


a2ss32 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE :: 7:37 PM EDT Issues on a2ss32 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.