[RESOLVED] MI3-SS31 :: Service Interruption Sunday 18th August 2019 05:53:26


MI3-SS31 :: is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE :: 10:02 AM EDT Issues on MI3-SS31 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.