[RESOLVED] MI3-SR5 :: Service Interruption Saturday 17th August 2019 10:59:15


MI3-SR5 :: is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE :: 3:04 PM EDT Issues on MI3-SR5 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.