[RESOLVED] Arizona DC :: Service Interruption Thursday 15th August 2019 14:07:00


Some servers in our Arizona Data center are currently experiencing intermittent network interruption. Users hosted on these servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 18:45PM EDT:   This has been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.