mi3-wtr1 :: Service Interruption Thursday 8th August 2019 16:01:59


mi3-wtr1 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 09:40PM EDT: Our Systems Operations team is still working on this. We will provide updates as more information becomes available.

UPDATE 10:40PM EDT:  Issues on mi3-wtr1 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.