[RESOLVED]Michigan :: Partial Service Interruption Tuesday 30th July 2019 16:34:33


Our Michigan facility is currently experiencing a service interruption on a small number of servers. Some users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 9:30 PM Eastern ::  Service has been restored for the affected servers.