[RESOLVED]MI3-SS17 :: Service Interruption Wednesday 24th July 2019 11:35:34


mi3-ss17.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team are investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 04:21PM EDT:  Issues on mi3-ss17 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.