[RESOLVED]SRC4 :: Service Interruption Wednesday 17th July 2019 11:30:06


SRC4 is currently experiencing a service interruption. Users hosted on this server will experience brief service degradation as a result. We will provide updates as more details are made available.

UPDATE 04:30PM EDT: Issues on src4 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.