[RESOLVED]mi3-ss7 :: Service Interruption Wednesday 17th July 2019 09:07:50


mi3-ss7.a2hosting.com is currently being rebooted to correct an issue. Users hosted on this server will experience brief service degradation as a result. We will provide updates as more details are made available.

UPDATE 1:10 PM EDT: Our System Operations team has corrected this issue and the server is back online.