[RESOLVED]mi3-wts2.a2hosting.com :: Reboot Required Thursday 27th June 2019 05:12:22


UPDATE: 9:28 AM EDT:: The server restart was completed and all services are working as expected.