[RESOLVED] MI3-WSS3 :: REBOOT Required Wednesday 5th June 2019 07:04:53


mi3-wss3.a2hosting.com is currently being rebooted to correct an issue. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available

UPDATE As of 11:10 EDT:   Our System Operations has corrected this issue and the server is back online, please get in touch if you are having difficulties.