[RESOLVED] MI3-WSS3 :: REBOOT Required Monday 3rd June 2019 11:09:37


mi3-wss3..a2hosting.com is currently being rebooted to correct an issue with Plesk. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE As of 14:57 EDT:   Our System Operations has corrected this issue and the server is back online, please get in touch if you are having difficulties.