[RESOLVED]Singapore data center :: service interruption Monday 22nd April 2019 23:29:10


 Singapore facility is currently experiencing a service interruption. Users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 4:00 AM EDT: The issue has been removed and we no longer see any issues with the connection.