[RESOLVED]Domain registration issues Tuesday 16th April 2019 23:04:31


Our domain registrar is currently experiencing technical issues. Due to that, no changes on domains, including updating contact information or changing nameservers on the domain registrar side, can be done. This does not affect DNS queries and it won't cause any service interruptions. This post will be updated as soon as we'll have any more information available.

UPDATE 3:45 AM EDT: The issue has been resolved and all domain registration actions should now work.