[RESOLVED] A2SS29 :: Service Interruption Monday 8th April 2019 07:39:32


A2SS29  is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 11:50 EDT:  Issues on A2SS29 have been resolved. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.