[RESOLVED]a2ss21.a2hosting.com :: Service Interruption Tuesday 26th March 2019 20:12:57


Server A2ss21 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 1:35 Am EDT: The server is back online.