[RESOLVED] MI3-SR12 :: Service Interruption Wednesday 20th March 2019 16:13:11


MI3-SR12   is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 20:20 EDT:  Issues on  MI3-SR12 have been resolved. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.