[RESOLVED]mi3-ss33 :: Service Interruption Tuesday 19th March 2019 06:18:58


mi3-ss33.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team are investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 10:53 AM EST: Our System Operations team has corrected this issue and all services are back online at this time.