[RESOLVED] MI3-SR7 :: Service Interruption Tuesday 12th March 2019 13:40:57


MI3-SR7 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 5:50 PM EDT: MI3-SR7 is back online and working correctly.  If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.