[RESOLVED]mi3-sr12 :: Service Interruption Wednesday 6th March 2019 05:26:31


mi3-sr12.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

Update 10:45 AM EST: Our System Operations team has corrected this matter and all services are online at this time.