[COMPLETED] Arizona Datacenter :: Network Maintenance Thursday 14th April 2022 20:00:00


Start Date: Friday, April 15, 2022

End Date: Friday, April 15, 2022

Time: 12:00 AM - 1:59 AM EDT (Thursday, April 14, 2022, 10:00 PM - 11:59 PM MST)

Description: Our Network Engineering team is performing network maintenance in our Arizona Datacenter. Users may experience a brief service interruption while the routine maintenance is performed. We will provide updates as they're made available.

UPDATE 12:00 AM EDT (10:00 PM MST): Our Network Engineers are starting the maintenance as scheduled. We will post an update as more information becomes available in this regard.

UPDATE 2:47AM EDT (12:47 AM MST): Maintenance has been completed at this time. Services are once again available.