Amsterdam Data Center :: Connectivity Issues Monday 11th April 2022 13:28:58


Our Network Engineering team is currently investigating reports of intermittent connectivity issues in our Amsterdam data center. Our Network Engineering team is aware of this issue and working diligently to rectify the situation. We will provide further updates as they're made available.

UPDATE 7:40 PM ET: Our Network Engineering team continues to work toward restoring all services. We will provide updates as they're made available.

UPDATE 9:21 PM ET: We have resolved the connectivity issue in our Amsterdam data center. Please reach out to support should you encounter any issues.