22nd February 2019

[RESOLVED] MI3-SR13 :: Service Interruption

MI3-SR3  is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 17:30 EST: Issues on MI3-SR13 have been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.