21st February 2019

[RESOLVED] A2SS25 :: Service Interruption

A2SS25 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE  9:15 PM EST: A2SS25 is back online. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.