21st February 2019

[RESOLVED]Update Maintenance :: A2LS10

To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server A2LS10. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available. 

UPDATE February 22nd 12:20 AM EST Maintenance on A2LS10  has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.