20th February 2019

[RESOLVED] A2SS27 :: Service Interruption

A2SS27 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 19:20 EST: We are glad to report that all issues with A2SS27 have been resolved.