19th February 2019

[RESOLVED] MI3-SR12 :: Service Interruption

MI3-SR12 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 23:20 EST: MI3-SR12 is back online.