17th February 2019

[RESOLVED] sg1-wts2 :: Plesk login interruption

We are currently aware of and working on restoring service for the Plesk login functionality on sg1-wts2.a2hosting.com. We will provide additional updates as they become available.

UPDATE As of 11:40 PM EST This issue was resolved by our Windows team and you can now login to Plesk as normal again.  Many apologies for any inconvenience caused.